Host port USB keyboards

Upon receiving my Axso, I tried using my Arturia Keystep ( the original 32 key model , which has a female micro-USB port) on the USB Host port. The result: after a few seconds of playing, notes started getting stuck, and finally Akso would stop responding until power cycle. This was the same using various mono and poly synths in the Factor and Community Libraries.

This same Keystep works perfectly on Axoloti.

So, since this was the first time using a new USB C to micro-USB cable from Amazon, I figured I’d try different cables.
Ordered and received two USB-C to USB-A adapters from Amazon. These would allow me to use my existing USB-A cables.

Result: Keystep fails the same as before. Conclusion - it’s not a cable problem.

I then tested some other USB keyboards. These all use USB-B connectors, so I used them with the USB-C to USB-A adapter, and appropriate USB-A to USB-B cables:

  1. ancient (10+ years) Edirol PC-50. I’ve had this forever. Works correctly.
  2. Alesis Q49 - pretty old, I think. Works correctly
  3. Arturia Minilab MKII. About a year old. Works correctly

(added later: these were all running on bus power. Keystep fails on bus power and with wall wart)

In summary, only my Arturia Keystep misbehaves with Akso. This keyboard works correctly with Axoloti, and with my Mac. It just works.

It would be interesting to see if anybody else has trouble using the Arturia Keystep with Akso.

it most definitely seems to be an issue with the keystep, if you google keystep problems you get a long list. this is particularly interesting:

it would be interesting to know how they fixed it. also i suspect that legacy axoloti (since it uses different midi code) is not affected.

you could install a midi-monitoring application and run that on your pc/mac with connected arturia and check for unusual things…

I haven’t seen any problems using keystep on Mac, or on Axoloti. From a quick search for keystep bug, most seem to be about the sequencer.

I’ll just use Axoloti.

There seems to be an issue with some MIDI devices on Akso, particularly bus-powered ones.

It also looks like it is probably fixable in a firmware level. Nick is trying to figure it out.

The Keystep misbehaved the same way when powered with a wall wart. The other three worked fine under bus power.

So, in the case of this Keystep, I don’t think it’s about bus power, or cables, but it would be interesting to know if other Keystep 32 users observe similar behavior.

Oh, I didn’t realize other bus-powered stuff had worked. Huh. My nanoPAD2 isn’t working but I don’t use MIDI much anyway.

I have a keystep and an AKSO (hopefully) arriving soon… I’ll see if I have the same behaviour. No problems with buspower on the axo, nor buspowered through usbC from my OP-Z

Excellent. Be sure to specify which Keystep you test, there are THREE Keystep models now.

i tested usb host and mpk mini play and launchkey mkII do not work (yet)
usbMidi arduino works
novation impulse works
yamaha pss a50 works (arp and record not fully tested)
old M audio keyrig works

1 Like

After a quick initial test:

novation remote 61 SL MK1 & Remote SL Zero MK1:
Both work and don’t require an external power supply like they did on axoloti


Elektron Digitakt works (has to be in configured in usb midi mode, does not work in usb audio/midi mode)


Hey all =)
just received the precious, and no luck so far with those controllers :

  • Akai MPK mini (USB powered)
  • Novation Launchpad X (USB powered)
  • Korg nanoKontrol2
  • Linnstrument (external PSU or USB powered)
  • Android phone

the 3 first controllers unfortunately don’t have optional external power possibility, but also none of them show the slightest sign of any power arriving (even the nanKontrol which is super “light”). The Android phone also doesn’t detect the USB connection. I have of course test my cables and adapters with other synth and they’re ok.

edit: I’m starting to think my Akso unit has a USB host port hardware failure…

Hi @zgui,

Sorry to hear you’re having trouble! The USB ports in this current batch are soldered on
by hand (by me), so it’s not out of the ordinary that there’s a bit of residue on the part itself. All ports are tested before they leave my lab, but it’s possible that there was a shipping mistake. It doesn’t seem like there’s obviously a short in the image you shared via email. Do you have a multimeter with a continuity tester? I’ll walk you through the debug process. I need to prepare a document with debug procedures so we’ll have it for future reference. It’s also possible that damage occurred during shipment somewhere else on the board.

Of course if we determine that there is a workmanship issue, I will send you another board.

I’m going to open another thread: I think I have a hardware workmanship issue. How should I proceed?