MIDI from Axoloti to Akso trouble, how do?

So I received the Akso today and tried to use my Axoloti as a way to get MIDI from a DIN port to USB form but it doesn’t work and I have no other gear to help me locate the reason. Here’s my Axoloti patch.

Choosin DIN as output passes the data through as it should at least.

And here’s my patcher in Akso. It works with notes coming from the virtual MIDI keyboard but no luck otherwise.


Axoloti and Akso are connected to different computers and there’s a USB-A to USB-C cable between them.

Please help, I want to use a keyboard to play!

Was struggling with this myself a while ago, but didn’t go in depth, as at that time I stumbled across a bug where no midi could be sent out the host port of the Akso, Nic is aware (there’s a bug report on Github)

Thing is the USB A port on the Axo is Midi Host, and if you have connected the Device port of the AKSO to the computer for power & patching then conversely the usb C port you plug in to AKSO from AXO is also the Host port (I recall Nic saying that this particular port can be either and has a chip to detect which it is)

However the relationship should be Host to Device with back and forth communication (bug notwithstanding), not Host to Host, as far as I’m aware, please someone correct me here, So I suspect that both ports cannot simultaneously be Device ports.

I tried to Power the Akso from the Host port of my Axo, plugging into the device USB C port and booting into a patch from the sd card at startup but was unsuccessful, no power up leds and a high pitched whine emitted…at that point I gave up until the midi host bug was fixed.

I have been successful using Host mode and controlling parameters with the Novation Remote SL MK1 keyboard and Zero and also The Digitakt, so it does work (again bug notwithstanding)

I am on a Mac and could theoretically use the IAC driver or some other program to translate midi from Akso to Axo on the same computer but have never attempted to and wouldn’t know where to start on windows something like MidiOX or Midipipe to translate …no idea Sorry do you use a DAW? Din Midi from Axoloti into daw and then out via an external midi instrument to Akso as a midi device perhaps

1 Like

Thanks for the explanation, saves me time to not try again tomorrow. I guess I can use Reaper in the middle, does the Akso somehow appear in there if it’s connected? In this case I would skip the Axo and just go from keyboard to computer, I have a Scarlett interface with the usual MIDI I/O

(I might as well add that I am very excited about this board and happy that I waited it out. First test with a 16 voice poly patch + reverb sounded great and wouldn’t have been possible on the Axoloti)

Yeah it should show up as a midi device, you’re right of course patience is key, Akso will be a monster when Nic gets a bit of breathing room…I wasn’t there but I’m sure there were a hell of a lot of teething problems when the Axoloti first arrived, but I love that board and am very excited about the possibilities of Akso

1 Like

I don’t see it, just the same MIDI devices as always :frowning:

shows up in the mac in logic and in audio midi settings, not familiar with Reaper, do you have to add new midi devices or should they be available to you in the same layer/dropdown as the scarlet midi automatically?

edit, quick google search yields:

Load Reaper , go to Options->Preferences->Audio-> MIDI Devices and in " MIDI inputs to make available (selectable as track inputs, etc.)" you will find it. Right-click on it and check Enable input and Enable input for control messages (assigned in actions menu)

any use or tried it already?

This seems to go down to the nuts and bolts

1 Like

Yep that’s the place where MIDI devices usually appear. Right now I have the Scarlett, Analog Heat and Elektron TM-1 in the output menu but no Akso.

Unfortunately that’s me out of ideas, I know not the Windows…“have you tried turning it off and on again?”

1 Like

Same on your other machine?

Good call. Indeed on my old computer running win7 it does appear as a MIDI device. I think it’s a driver issue but don’t know how to fix it. I just plugged the Akso in it for the first time and Windows installed some driver automatically. When I set it up on the new computer I followed the installation instructions.

1 Like

Dope, well at least you can strike those keys on ol’ 7, till you figure out what’s going on with the new kid, hopefully with lashings of Heat for good measure …good day/bad day

1 Like

I’ll see how it goes, that computer has some other problems :smiley:
Thanks a lot, I hope I can get the Akso patcher running on there as well.

1 Like

you’ve had enough problems for one day…save that patch with the poly and the reverb, save it to SD card as startup, and trigger it as a midi device on the old boy

No more software mysteries for you tonight

1 Like

So to verify and out of curiosity, I connected the device port of the Axo to the midi host port of the Akso, and created a simple saw osc and mixer patch with tuning and level controlled by midi cc. I then connected the gpio pots on the Axo to a midi/out/cc thin outputing the midi device port 1 and was able to control both tuning and level cc’s on the Akso and it works.

So I included a matroe/midi/thru ch in the axo patch with input set to din and output set to usb device 1 and was able to control the same cc’s via the digitakt on the din input of the Axo

So if you do the same and upload a patch on the Axo with the thru object , connect your din keyboard to the axo and then remove the device port connection and connect it to the host port on the Akso (i used a usb A to C adaptor) then you should be good to go

1 Like

The device port on Axoloti is the micro USB port? Good to hear you had success, I’ll try for a bit tomorrow and also start looking for an adapter cable.

Yes the micro usb port, so after the patch is uploaded it remains attached to the Axo device port but you remove the connection from the computer, and then that connection gets plugged into the host C port of the Akso…so if you have a usb C to micro usb cable you are sorted, otherwise you need an adaptor for that Usb A connector (that connects to the computer) to convert it to C…

There is one caveat; I am powering the Axo via a 9v wallwart, so I am not relying on the computer to provide the Axo with power.

1 Like