Tried to update firmware and now just blinking green LED

I tried to update to the latest firmware and I am just getting a rapid blinking green led and patcher doesn’t connect. Has anyone had this issue?

Nevermind i was able to do flash rescue… whew. My sd card bracket is coming loose though :frowning:

Hey, sorry for reviving this post, but I´m having the same problem.
Something went wrong when trying to update the firmware and the akso went totally dead.
Starting it in dfu mode it appears on the device manager, and I installed the drivers with Zadig.
Doing a firmware update (flash rescue) seems to work, and it says it has updated the firmware, but now when I connect it Windows still doesn´t recognize it and all I get are quick bursts on the green led.
Do you remember if you did anything special to get the rescue to work?

Ok nevermind.
It seems like there is something wrong either with my Windows machine or with the Windows Akso Patcher. I did a flash (rescue) on a linux machine and it worked.
I got my akso running again! :smiley:

2 Likes