Why Aren't Libraries Loading?

Having issues with this. Error code below. Second install; no solution to be found there.

Thoughts, tips?

Library sync failed. Cannot find submodule: community (3.0.1,anon)
Loading path: C:\Program Files (x86)\akso-3.0.1\akso-factory\objects
Loading path: C:\Program Files (x86)\akso-3.0.1\objects
Loading path: C:\Program Files (x86)\akso-3.0.1\akso-community\objects
Object libraries loaded successfully.

1 Like

Tried manually copying the community and factory object libraries from GitHub into the Akso folder - no luck there, either.

1 Like

Weird! The directory is there but the Patcher doesn’t see it?

I’ve been tinkering with it. Tried a few naming conventions in my C drive, and I can get the patcher to load both factory and community objects so that I can test patches / go live, but then I get this:

java.io.FileNotFoundException: C:\Program Files (x86)\akso-3.0.1\build\xpatch.cpp (The system cannot find the path specified)
Generate code complete
Compiling patch.
‘C:\Program’ is not recognized as an internal or external command,
operable program or batch file.
shell task failed, exit value: 1
Compiling patch failed.
axoloti.shell.ExecutionFailedException
axoloti.shell.ExecutionFailedException
at axoloti.shell.ShellTask.run(ShellTask.java:120)
at axoloti.shell.ShellTask.lambda$getJob$0(ShellTask.java:37)
at axoloti.shell.CompilePatch.lambda$run$0(CompilePatch.java:67)
at java.base/java.lang.Thread.run(Thread.java:834)

axoloti.shell.ExecutionFailedException
axoloti.shell.ExecutionFailedException
at axoloti.shell.CompilePatch.run(CompilePatch.java:75)
at axoloti.live.patch.PatchViewLive.lambda$goLive$7(PatchViewLive.java:275)
at axoloti.job.JobProcessor.lambda$exec$0(JobProcessor.java:21)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)

Man. I don’t know much about Windows. In a *NIX I’d check permissions. Can you do that?

You should report this on the Git.

Hi @invisibleman. Sorry to hear that you’re having trouble. Can you give me specifics about your system configuration? What version of Windows are you running?

This looks like a possible bug with how the actual path C:\Program Files (x86) is being handled as a string. There’s no reason for the akso-3.0.1 directory to be in Program Files (x86). That obviously shouldn’t break things, but to confirm my suspicion, can you install in a neutral location without any spaces or parentheses in the path name? Something like C:\akso-3.0.1 or C:\Users\SomeUsername\akso-3.0.1. Do this with a fresh copy from the release archive and allow the libraries to sync normally. Don’t try to move around the existing installation; it might be in a corrupted state.

‘C:\Program’ is not recognized as an internal or external command suggests to me that things are being split on the space mistakenly, i.e. some longer string that should be interpreted as a command is being cut off.

Thanks for the reply. I re-installed it in the directory per your instructions, and things are working now.

1 Like

Hm, seems like I’m having a similar problem as invisibleman- I’m on Mac running Catalina 10.15.6. Getting the same message:
Library sync failed. Cannot find submodule: community (3.0.1,anon)
Loading path: /Users/sebastiansack/Library/Akso/akso-factory/objects
Loading path: /Users/sebastiansack/Library/Akso/objects
Loading path: /Users/sebastiansack/Library/Akso/akso-community/objects
Object libraries loaded successfully.

No objects are showing up in the object selector if I create a new patch and double click, libraries are empty when I look in file->library. Any tips?

@killershrimp This is the first time I’ve seen anything like this on MacOS. Is it possible that you’re behind a firewall or have some other security system in place that might be blocking traffic for the patcher app?

Open a Terminal and run which git and paste the output here. The patcher uses a library for git interaction, but I want to test if you can clone the libraries from your machine at all. If which git returns a path and not an error, run git --version and paste the output here. If git is unavailable, i.e. if which git returns an error, install it. Then from a convenient directory like /Users/sebastionsack run git clone git@github.com:zrna-research/akso-factory.git. Ideally this will clone the repository to a subdirectory of the directory you chose called akso-factory. If this fails for some reason, try git clone https://github.com/zrna-research/akso-factory.git instead.

Let me know if this all works, and I’ll help you debug from there.

2 Likes

I’m also running Catalina. If I recall, I had some related library issues with the beta, but we resolved that with the current version.

If it’s not working out, I can be a separate data point.

(Very often these things have to do with security stuff in Catalina. It could be that it can’t read a directory or something.)

1 Like

Great, thanks! I’ll take a look at this as soon as I have time and get back to you on here. I’m not using a firewall or any other security products/sytems. Thanks so much!

Ok, I ran which git as well as git --version: going to paste the output from both below. Sorry I’m unfamiliar with Terminal - pretty new to this side of things!

Sebastians-MacBook-Pro:~ sebastiansack$ which git
/usr/bin/git

Sebastians-MacBook-Pro:~ sebastiansack$ git --version
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Quick update: not sure what I did differently, but I deleted the app/associated files and redownloaded from github, libraries are loading successfully now.

1 Like

That seems to be solving a surprising number of glitches. Wish I could understand what was going on there!

1 Like